Vous n'êtes pas identifié(e).

Forum AccessDV Linux

Pour les débutants et déficients visuels. QR Code URL site ADVL

#1 Le 21-09-2017 à 19 : 06

Ecrit par Yan
Membre

[Résolu] Problème focus de souris

Bonsoir.

Nous rencontrons un souci mon ami (l'utilisateur non voyant) et moi.
En effet, le curseur de la souris, active automatiquement le focus sur sa position.
Par exemple, nous lançons le menu déconnexion ou bien Firefox et si le curseur de la souris se trouve au dessus de la fenêtre en question, tout va bien.
Si le curseur se trouve en dehors de la fenêtre, le focus rend actif le bureau et ceci sans cliquer sur la souris et même si elle n'est pas branchée.

J'ai réinstallé la distribution car je l'avais mise à jour avec Compiz 3.14. Là je suis bien avec la version 3.12.

Avez vous des pistes pour remédier au problème car là, nous séchons  tongue

Yan et Marc.

ps : j'ai tenté des raccourcis clavier du style ALT+Tab, Ctrl+Tab pour revenir sur la fenêtre lancée, aucun succès.

Dernière modification par Yan (21-09-2017 à 19 : 09)

Hors ligne

#2 Le 22-09-2017 à 07 : 28

Ecrit par Mélanie
Administrator

Re : [Résolu] Problème focus de souris

Bonjour, souci jamais rencontré encore.
Trois questions : orca était-il activé ? Y avait-il une souris externe ? un clavier externe ?
Nous recommandons vivement, si vous utilisez un ordinateur portable, l'emploi d'une souris externe et d'un clavier externe.
Rendez-vous téléphonique fixé par message privé.

Hors ligne

#3 Le 05-10-2017 à 17 : 17

Ecrit par Yan
Membre

Re : [Résolu] Problème focus de souris

Bonjour.

Suite à nos différents échanges téléphoniques, je fais un compte rendu pour les lecteurs du forum sur la résolution des problèmes rencontrés.

Merci d'avoir envoyé une clé de la dernière version du système à Marc.

Les soucis que nous avions étaient liés à la carte graphique. En effet, dès que j'en ai "changé", tout à bien mieux fonctionné.

Pour information, j'ai mis en place une "ancienne" carte vidéo ATI série 3xxx (Je ne me rappelle plus le modèle exact).
Avant cela, on utilisait le GPU intégré au CPU (chipset Intel HD Graphics 510).

Je n'ai pas pris le temps d'essayer d'installer un quelconque pilote pour ce chipset graphique. Il en existe peut être un.

Comme vous nous avez parlé au téléphone de problèmes rencontrés sur les chipsets Nvidia cela m'a mis la puce à l'oreille.

Voici la liste du matériel utilisé :

Carte mère : Gigabyte H110M-S2V lien vers les infos constructeur ici
Processeur : Intel Pentium G4400 (3.3 GHz) Socket 1151 - Dual Core - Cache 3 Mo - Skylake Lien vers les spécifications ici
Mémoire :  DDR4 G.Skill Aegis, 4 Go, 2400 MHz, CAS 15 spécifications ici
Disque dur Western Digital Raptor 36 Go 10000 trs/mn
Clavier standard en PS/2
Souris Logitech USB

Encore merci pour votre patience et votre gentillesse.
Yan, le technicien de Marc.

Hors ligne

#4 Le 05-10-2017 à 21 : 53

Ecrit par equipe-advl
Administrator

Re : [Résolu] Problème focus de souris

Bonjour,

Les cartes mères ou les cartes graphiques récentes nécessitent des ajustements particuliers, soit par exemple, l'installation d'un pilote propriétaire, d'un firmware spécifique ou d'un Kernel plus évolué (mais attention, l'installation d'un nouveau Kernel peut induire de ne plus pouvoir lancer le server graphique), etc...

Dans le cas des cartes Intel HD 510 Skylake récentes, il faut procéder ainsi :

1) Ouvrir un terminal en faisant : Win + T

2) Saisir ce qui suit :

echo "deb http://ftp.fr.debian.org/debian/ jessie-backports non-free contrib main" | sudo tee /etc/apt/sources.list.d/backports-jessie.list && sudo apt-get update

3) Puis :

sudo apt-get install -t jessie-backports firmware-misc-nonfree xserver-xorg-video-intel && sudo apt-get install xserver-xorg-core libegl1-mesa libegl1-mesa-drivers libegl1-mesa libgl1-mesa-glx libgl1-mesa-dri

4) Enfin, on désactive les backports par :

sudo rm -vf /etc/apt/sources.list.d/backports-jessie.list

On redemarre le PC et la carte graphique sera fonctionnelle !

Hors ligne

Pied de page des forums

Propulsé par FluxBB 1.5.10